CPA Secure

Please Read Before Login:


1. BROWSER COMPATIBILITY
- Internet Explorer 11.0 - For best results consider using IE 11.0 and install the Active-X Upload/Download Wizard upon initial login. This should be a one-time install per computer used to access this site.

- Mozilla Firefox can be used provided you are running JAVA 8.0 or later. Install JAVA 8.0 or later first. Then install the Upload/Download Wizard for JAVA after logging in for the first time. This should be a one-time install per computer used to access this site.

- Google Chrome does not currently support JAVA 8.0 or later as it relates to the Upload/Download Wizard. You may still use Google Chrome, however files will need to be uploaded and downloaded individually and this browser currently lacks the many "easy of use" benefits of the above listed browsers when combined with the Upload/Download Wizard.

- Windows 10 Edge Browser does not support Plug-ins and therefore will not run Java or Active X. If you are running a Windows 10 with the Edge Browser please switch to Mozilla Firefox or Internet Explorer 11.0. If you are have problems accessing IE 11.0 on your Windows 10 system, type "IE" in the 'Search the web and Windows' bar in the lower left area of your desktop and then click the Internet Explorer link that appears.

2. SECURITY NOTICE - You are about to access a secured resource. CPA Secure reserves the right to monitor and/or limit access to this resource at any time. Any attempts to gain unlawful access to this site will be prosecuted to the fullest extent the law will allow.